Medium Format Forum

Register a free account now!

If you are registered, you get access to the members only section, can participate in the buy & sell second hand forum and last but not least you can reserve your preferred username before someone else takes it.

Problems with 500 CM


New Member
Hi all, I think it is better to begin a new thread instead of continue my old one. I've purchased my first Hasselblad 500 C/M. But I've found these surprises.
1) I'm no more able to use knob for film advance and shutter cocking. Even if a film is loaded nothing happnes, all is blocked. Why? Could it be because the lens, a 80 mm Planar C was mounted without cocking lens mechanism?
2) I'm not sure but I've doubt about shutter working. In my opinion it has problems expecially with long times. But I can't test it because of the point no. 1!

What can I do?

Thanks all

Hello Pierangelo I have a 500 C/M with an 80mm Planar T* lens, and I recently had trouble connecting it to a 2x extender. Looking in the instruction book, I noted that the shutter must be cocked to be able to connect. There is a little slot inside the back of the lens, which points to a red dot. If it is not aligned to the red dot, the shutter is not cocked. Using a small coin, not a screwdriver (in case you slip and damage the glass), this slot should be turned clockwise one complete turn, until it clicks into place opposite the red dot. When I followed the instructions it worked perfectly. The shutter is then cocked and should work when refitted to the camera body. I hope this helps. You can read these instructions with diagrams if you download the Hasselblad 500 C/M instruction booklet from the Hasselblad website. If you have difficulty let me know and I can email you a copy. Best wishes Brian Parker
Hello Brian, I've still red about this but the fact is that I was able to mount Planar WITHOUT cocking shutter turning the slot counterclockwise for few degrees. In this way it was aligned with the one insede camera, but mounting it in this way is WRONG even if possible. So now I've a locked lens on a locked camera. Desperation!!! Is there anything I can do?
Hello again Try taking the A12 back off to see if you can cock the shutter with the knob. If the slot and the piece that fits into it are aligned, they might still operate together. Brian
I've forgotten to say my A24 back has not the slide.... so it is not possible to remove it. But this seems a good idea. Thanks!
If the camera has already been fired 24 times with the A-24 film magazine attached, the camera will not fire, because it thinks that it is out of film. Remove the spool holder (insert) from the film magazine, then put it back in, and wind the film magazine to #1. The camera should fire then.

Dave Odess
Hello again Pierangelo Did you manage to fix the problem? If not, you might try to buy a slide to fit your A24 back. I have seen them for sale for about $15. Also, if you use an A24 back, do you have a source of supply for 220 black and white film? Best wishes Brian
I find it is still easy to get the Kodak TXP 320 in 220 format in the Netherlands. Others I haven't tried to purchase. Jeroen
Thank you Jeroen. Can you let me have some details of suppliers of TXP 320 in the Netherlands? Best wishes Brian
Hi all, after few days I have the solution about my firts post. It is as simple as obvious: I've sent my Hasselblad to a qualified repair who solved the problem.