Medium Format Forum

Register a free account now!

If you are registered, you get access to the members only section, can participate in the buy & sell second hand forum and last but not least you can reserve your preferred username before someone else takes it.

H1 with Zoom problems


New Member
Has anyone experienced an erratic problem with the H1 and zoom lens. Mine every so often comes up with lens error, red triangle, often different error numbers, therefore rendering camera non functional, v annoying during shoot. . Turning on and off sometimes resets camera to normal or removing battery pack works but then error will happen again maybe after a few frames or after a few films! I am losing heart with this, have latest software from Hass UK , often end up going back to my nikon.
Hi Adrian,

I used to experience the same problems with my 80mm, but after upgrading the software and the lens, it seems to be gone.

I think the lens upgrade included replasing the connector(s). Also make sure your connectors are clean.

Software is 8.2.1 installed by Hass service here in UK . The camera is less than 3 months old. I will have to go back to them again.
I also have been having this problem, but with a 80mm and 150mm lens. My software version is the same 8.2.1 and was only upgraded a few weeks ago, if anything it is now worse! I have agreed with my supplier to get a replacement camera - in fact Hasselblad UK agreed that a refund was appropriate but my supplier is very unwilling to do that, so am going for the new camera! Might sell the new camera unused and the 150mm lens and a
Would I have this problem if I purchase now ? Has there been a recall of the lenses or could I be unlucky and get some old stock with the problem. Is there any offical word from Hasselblad on this ?
Since last upgrade Camera is performing perfectly, Hass uk replaced connectors and installed latesat version software, for last two week s have not seen that horrid red triangle which was driving me to near insanity every time I picked up the camera.
What is lens problem ID 44:5, 19:1, AF problem ID 83:2, lens problem ID 44:6, and no CBC ? We have firmware 8.2.1. Just tried R&R battery pack and now it works! Is there a problem with trying to use my SB28 in the auto or manual mode?