Medium Format Forum

Register a free account now!

If you are registered, you get access to the members only section, can participate in the buy & sell second hand forum and last but not least you can reserve your preferred username before someone else takes it.

Studio flash not working with Hassy 500 cm


New Member
I connected my pc synch cord to the socket on the lens and the other end to my primary flash. When I depress the shutter or the flash-test button on the lens (80mm CF) nothing happens. Is there anything else that I need to do use my camera with a studio flash setup? Thanks.
I'm afraid not.
In most cases of flash failure, the cable is to blame. Have you tried another cable?

If that doesn't work (i.e. the cable is not to blame) try another lens.
The PC socket itself or the synch inside the shutter could of course be where the fault lies too.

If the flash wil not fire using another lens too, the fault will be in the unit (start suspecting the cord socket first).

By the way, there is no flash test button on a CF (or any other) lens.
What button did you try?
Thank you for the speedy reply.

Unfortunately, I don't have the lens in front of me. There is a little green button towards the very front of the lens, possibly along the same row of numbers as the shutter speed, on the very left of the numbers, that I believe says something like "flash." That is what I have been pressing to test the flash. Depressing the shutter also doesn't work.

I used the synch cable with a different camera and it worked fine. Ugh, I hope the problem is not with the lens. I will test that also.

The green button that says 'F' next to it is probably the catch release to allow you to set the lens in 'F' mode for focal plane shutter cameras (2000/200 series), if the lens is set in this mode, then the sync probably will not fire. Make sure that the lens is not set to 'F' when testing your set up, but to an actual shutter speed. Then follow Q's sound advice.

Ah, that's good info. I actually could not set the lens to "F" mode although I tried (it doesn't turn quite that far). I merely pressed the button several times. I will leave it alone in my future testing.


Since I only have the one CF lens (an Apotessar—I prefer the old C lenses for some strange reason), I wasn't quite sure if there wasn't another control that Djana could be refering to. I wanted to leave the door open for you to correct me if I was wrong, or to let Djana give a better description of what she was doing. I did guess pretty well with my dodgy memory... I wasn't sure about the flash sync, but it made sense to me if the lens shutter was disabled, the sync on the lens wouldn't fire. Though I may disagree with some of your opinions, your technical grasp of the Hasselblad system, in general, is superior to mine.

And I got you to post on light grey twice in one thread...